PHP is among the most widely used server-side programming languages. It is quite popular since it is free software, which you can use to build interactive websites such as social networking websites, e-commerce portals or online teaching portals rather than static HTML websites. A PHP module must be enabled on the web server where a PHP site is hosted so that its source code can be ‘translated’. Because there aren’t any license fees for this kind of module and the language provides countless possibilities for the web-based apps that you set up, there’re 100s of millions of PHP-powered sites. What’s more, there’re tons of open-source PHP scripts, which you can use for your sites without having to possess any coding experience. Considering the fact that there’re a number of versions of PHP, you should confirm whether the very same version that you used while setting up your site is present on the server as well.

PHP 4 and PHP 5 Support in Cloud Website Hosting

We’ve reached a decision not to prevent our present and future customers from picking the PHP version that their websites will use, which suggests that if you get a cloud website hosting package from us, you will be able to pick between versions 5.5, 5.4, 5.3, 5.2 and 4, not only for the hosting account itself, but also for each single domain name hosted by you. This can be done with just one single click of the mouse through our in-house developed Hepsia hosting Control Panel via which all shared accounts are administered, so you won’t need to possess any technical or programming abilities. You’ll be able to host sites built with both old and new PHP-based scripts without any hassle, so if you decide to leave your current hosting company and move over to us, you can be certain that all the sites that you’ve built throughout the years will continue to run correctly.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

If you have a site built using an older version of PHP and you’ve dedicated time and energy on developing it, plugging security loopholes and posting page content, you’ll need to find a hosting service that can support it, as nearly all hosting suppliers nowadays offer support only for the most recently launched PHP version and drop the earlier versions. We, on the other hand, have decided to let you choose the exact version that your own sites require. Our Linux semi-dedicated servers support multiple versions of PHP 5 and PHP 4, which goes to say that you will be able to use both older and newer scripts without losing any manual settings or wasting time attempting to make your sites compatible with the web hosting platform. You can change the current version through the Hepsia Control Panel and such an update will apply to the whole account, but you will also have the ability to select a different version for each single website hosted in your account by using an .htaccess configuration file.